Based on our internal testing, and reports from users who are early adopters of macOS 10.14 Mojave, Icon Pro Audio’s iMap software is not currently compatible with Mojave. The operating system causes the iMap software to crash upon opening. This affects the iMap software for all Icon midi keyboards and DAW controllers.

THESE COMPATIBILITY ISSUES DO NOT AFFECT THE PERFORMANCE OF ICON CONTROLLERS. They only affect the iMAP software which is used for firmware updates, and midi mapping.

Our engineers are currently working on a solution to this issue, and hope to have a resolution soon.

SUGGESTIONS FOR IMAP USERS:
In the meantime, if you plan to upgrade your Mac to Mojave, and you are using ANY Icon Pro Audio controllers, all of which require iMAP software for firmware updates and midi mapping, we suggest that you upgrade your firmware or midi mapping BEFORE you upgrade to Mojave.

Please download the latest version of your iMAP software from www.iconproaudio.com and perform any firmware updates or midi mapping operations first, and THEN update your operating system. This will ensure that you are able to execute the firmware update on an earlier version of macOS, and as such, you should have no problems.

AGAIN, THIS ISSUE SHOULD NOT AFFECT NORMAL OPERATION. ONLY THE IMAP SOFTWARE IS AFFECTED.

If you have any questions or concerns, please contact our technical support department in the Help Center at www.iconproaudio.com

Thank you,

Your Icon Pro Audio Technical Support Team